Environment
Canvas
MiVideo
Issue
Instead of the MiVideo media player loading, students see an Access Denied message.
Note: there is a current issue with embedded MiVideo media in Canvas that causes some media to randomly display Access Denied. The ITS-MiVideo team is working with the vendor to resolve this issue. The workaround is for the student to reload the page.
Resolution
The issue occurs when clicking a link to the video from within course content
Possible causes:
- The instructor uses a URL link to the video from the Media Gallery, My Media, or Kaltura Capture.
- There is no workaround unless the video is published in the Media Gallery, then students can find and watch the video there.
- Instructors will need to fix the video link using the instructions in the Publish Media in Canvas article.
- If the video was linked and then later the video was deleted.
- Instructors can contact the ITS Service Center for help determining if the video still exists.
The issue occurs when the video is embedded in course content
Possible causes:
- A known issue where some media randomly display 'Access Denied'.
- The workaround is to reload the page.
- If the video was embedded in course content and then later the video was deleted.
- Instructors can contact the ITS Service Center for help determining if the video still exists.
The issue occurs when clicking a video in Media Gallery
- Although rare, there could be a data sync issue
- From the instructor's My Media library within Canvas verify the video is listed as "Published".
- If the video is listed as "Private" yet the publish details page (click the title of the video from My Media > ACTIONS drop down > Publish) shows the media is published to the Media gallery, there was a data sync issue as the video cannot be both private and published.
- MiVideo will not play the video because the video is also private.
- Unpublish and republish the video (click the radio button for Private, Save, click the radio button for publish, check the box next to the course name, and Save). This will prompt MiVideo to sync properly (there might be a few minutes delay before the video shows "Published" in My Media).
Resources and Questions
For additional questions, please contact the ITS Service Center