Dell DisplayLink Dock Troubleshooting

Issue

Common issues related to Dell Universal Docks (UD22 / D6000)

  • Dock not being properly recognized by the computer
  • "USB Device Not Recognized"
  • Flashing displays
  • Blank displays
  • Peripheral connection issues

Dell Universal Docks are NOT compatible with Dell Wake On USB-C Dock functionality. Users must use the installed power button on the laptop itself in order to wake the machine from sleep/hibernate/shutdown. 

Dell Universal Docks require the installation of DisplayLink drivers on Windows machines in order to function properly. Additional software and setup is required for macOS and Linux machines, please see the related articles for more information on setting up such devices.

Environment

Computers connected to a Dell Universal Dock. The two most commonly found in our environment are the D6000 and it's successor, the UD22. 

Cause

Lack of the Dell DisplayLink Dock Driver on the target machine or because the firmware for the Dell D6000 dock has not been updated. 

Resolution

First, try installing the most current Dell DisplayLink Dock Driver. It can be found here, on Dell's support website. Administrative rights on the machine are required in order to install this driver.

If that does not solve your issues, you can try updating the firmware of the dock itself. The Firmware Update Utility can be found at the same link, and admin rights are required for this as well.

Please note: You will need to disconnect everything plugged into the dock before running the utility.

Caution: Do not disconnect the dock while the utility is running, as it may cause the dock to no longer function. The utility itself will walk you through the steps needed in order to update the firmware.  

If these steps have not resolved the issue it may be due to incompatible hardware or hardware failure, such as damage to the cord that connects the dock, the port into which you are trying to plug in the dock, etc. Email lsatechnologyservcies@umich.edu for further assistance troubleshooting the issue. 

Details

Article ID: 7926
Created
Thu 4/21/22 4:16 PM
Modified
Wed 1/31/24 1:53 PM