Issue
When attempting to update or install software on an Apple Mac computer through the Managed Software Center, no updates are found and/or software does not install.
Environment
- macOS
- OS versions ≤ N - 1
- eg. if macOS 14 is the most recent (N), it and macOS 13 (N - 1) are considered supported, anything else is unsupported
- Managed Software Center
Cause
Apple only guarantees timely security updates for the most recent version of macOS, and so the University has decided to follow this pattern of N - 1 to comply with security policies. To encourage updating to a supported OS, new software installs and updates are blocked though Managed Software Center with the exception of any potential security updates or patches.
Resolution
Please update your OS to a supported version of MacOS. As previously mentioned, only the 2 most recent version are supported.
If an OS version update is not available in your Managed Software Center, please contact LSA Technology Services at lsatechnologyservices@umich.edu or submit a service request on the web.