Issue
When printing to a departmental print queue from any given computer, regardless of whether it is a departmental or personal machine, you may find that your print jobs have been paused and are listed with a message that says something like “Hold for Authentication” or “On Hold (Authentication required).” This means that you need to provide credentials to the print server before your print jobs will be allowed to be submitted. Sometimes, the authentication window will pop up by itself, but often it won't.
Follow these steps for each printer you regularly use. If you don’t click the checkbox, the next time you submit a print job to this queue it will also be put on hold again and you will have to repeat these steps.
Please note: Any time you change your UMROOT password, you will also need to repeat the steps shown below.
Environment
Resolution
- Open up the print queue on your computer.
- Select the print job that is on hold.
- Go to the Jobs menu, and choose Resume Job
- Mac: curved arrow
- Linux: "Authenticate"
- A dialog box requesting credentials should pop up; enter your UMICH credentials
- On Linux: username should be in the form "UMROOT\uniqname".
- Check the box next to "Remember this password".
Please note: If you are not prompted for your username and password on macOS, please follow the steps below or contact us for assistance
Remove KeyChain Item - MacOS
- Open KeyChain Access.
- Search for the name of the printer in the list of items.
- Select it and press the Delete key.
- Alternatively; Right Click > Delete
- Remove any existing jobs from the print queue and resubmit the print job.
- You should now receive a prompt for credentials; enter your uniqname and password.
- Check the box next to "Remember this password".
Cause
The print server needs your password in order to authenticate you the first time you print, and was unable to retrieve it automatically from your computer. The credentials stored on the machine may also be outdated.