Resolving the Microsoft Office EXC_BAD_ACCESS error on macOS

Symptoms

When opening an Office application, an error window will appear called Microsoft Error Reporting. The error may read, "there was a problem and Microsoft Word was closed." The window contains a checkbox to Restart the application, an option for More Information, and an OK button. Restart does not resolve the issue.

Click on More Information to see the error log. In the error log, under Error Signature, will be the error code: Exception: EXC_BAD_ACCESS.

Environment

  • Operating system — macOS
  • Software — Microsoft Office, Word, PowerPoint, Excel

Cause

Error usually indicates a memory access violation, which means that the application is trying to access memory that it is not allowed to access or that it has already released. This can be due to a corrupted Office installation, conflicting software using the same memory resource, outdated software or possibly faulty memory modules

Resolution

Delete Microsoft Office preference list files, as well as the linkCreation.dotm add-in. Make sure to Quit all Office apps first.

  1. Open Finder.
  2. Click Go in the menu bar at the top of the screen.
  3. Click Go to Folder in the drop-down menu that appears.
  4. Type ~/Library then press the blue Go button.
  5. Open the Containers folder.
  6. Right-click or +click each of the following files (if present) and Move to Trash:
    • com.microsoft.errorreporting
    • com.microsoft.Excel
    • com.microsoft.netlib.shipassertprocess
    • com.microsoft.Office365ServiceV2
    • com.microsoft.Outlook
    • com.microsoft.Powerpoint
    • com.microsoft.RMS-XPCService
    • com.microsoft.Word
    • com.microsoft.onenote.mac
    • com.microsoft.Word.plist
    • com.microsoft.Word.prefs.plist
  7. Click the back arrow to go back to the Library folder and open Group Containers. Move each of these to Trash if present:
    • UBF8T346G9.ms
    • UBF8T346G9.Office
    • UBF8T346G9.OfficeOsfWebHost
  8. Empty the Trash.
  9. Open Word and in the menu bar at the top of the screen click on Tools → Add-ins.
  10. Select linkCreation.dotm and click the – (minus) symbol to remove (if present).
  11. Quit Word and re-open to test.

Details

Article ID: 2392
Created
Fri 5/29/20 2:02 PM
Modified
Wed 12/20/23 8:54 AM