Docking station not working after computer wakes from sleep/hibernation

Summary

A few standard troubleshooting tips for devices connected to docking stations that aren't functioning properly after resuming from certain sleep states.

Body

Issue

When a Windows computer connected to a docking station resumes from sleep, some or all of the devices attached to the dock are not recognized by the computer. Device Manager might show yellow exclamation points and Code 10Code 24, or Code 43 for those devices.

Environment

  • Windows 10
    • All editions

Cause

This is a known issue with Windows 10 and system power states.

  • Thunderbolt Dock is connected/disconnected during Modern Standby, Hibernate (S4), or Soft Off (S5) power state.
  • Fast Startup is enabled

Resolution

Simply disconnect and reconnect the USB-C Thunderbolt connection while the machine is awake.

External resources

Details

Details

Article ID: 6883
Created
Fri 12/10/21 2:33 PM
Modified
Wed 1/31/24 3:30 PM