ESET and Managed Software Center connection issues

Tags mac ESET

Resolving issues with the Izzy management system on macOS after a Mac cleaner tool has been run.

Symptoms

After running a "cleaner" application on a MacOS device, ESET Antivirus software no longer worked, along with the Managed Software Center to download and update software.

Error messages such as the following would appear in the Managed Software Center:

There is a configureation problem with the managed software installer. Could not start the process. Contact your systems administrator.

Error messages from ESET:

Your computer is not protected. There was a problem communicating with the ESET Background process, please try again. If the problem persists, restart your computer.

Environment

  • macOS
  • Managed Software Center
  • Izzy
  • ESET Endpoint Antivirus
  • Munki

Cause

The issues with ESET and Managed Software Center (MSC) not connecting were related to a Mac cleaner tool, cleanmymac x. The software likely removed some bits and pieces of the software used for Izzy (munki).

Resolution

With guidance from the Izzy team, reinstall the latest version of munki from the github repo (https://github.com/munki/munki/releases) and reboot the computer.

 Note: Make sure to customize the install and check the box to install the plist files.

Internal notes

This is a very generalized article. Please work with the Izzy team via Slack to communicate the issue, as there might be more that needs to be done beyond reinstalling Munki

Details

Article ID: 3204
Created
Fri 7/24/20 2:33 PM
Modified
Tue 9/8/20 11:51 AM